? Editing: Post:21.body Save Delete Cancel

ArchLinux.net

Welcome to the ArchLinux forum!

+ Create new topic
Please wait...

Title

Body
^1 ^2 added ━ submitted by user_name

Main ZeroNet news How did you find ZeroNet?

Getting zeronet running with tor

Additionally to the ControlPort stuff mentioned in the docs you have to do:

echo 'CookieAuthFileGroupReadable 1' >> /etc/tor/torrc
chmod g+xr /var/lib/tor/
usermod -a -G tor zeronet

if you want to use the ‘tor: always’ setting:

echo 'tor = always' >> /etc/zeronet.conf

… worked for me, had anyone have further issues?

^3 ^4 basxto posted on Mar 02, 2016
Please sign innew comment
user_nameadded ^1 ^2
Reply
Body
redfishon Apr 29, 2016 ^1 ^2
Reply

Btw, I'm just waiting for Tor 0.2.8 to reach the repos, at which point I will simplify the package to require less manual work (see details here: https://aur.archlinux.org/packages/zeronet-git/). But, I hesitate to fully automate the permission modifications in the PKGBUILD, because this doesn't feel right from the security perspective.

alphazoon Mar 06, 2016 ^1 ^2
Reply

Thanks for the fix.

basxtoon Mar 04, 2016 ^1 ^2
Reply

I got it fixed, I used a timer and modified the zeronet service (systemctl edit zeronet)

here is the files content (NullPaste)

You start the whole thing with systemctl start zeronet.timer

basxtoon Mar 03, 2016 ^1 ^2
Reply

we probably need to write an modified service-file which fixes the permissions

alphazoon Mar 02, 2016 ^1 ^2
Reply

Thanks for the additional information related to Arch.
It was not straightforward in my case since I was using Vidalia to start Tor so the cookie is located in ~/.tor/control_auth_cookie which requires an additional line in Vidalia torrc (~/.vidalia/torrc):
CookieAuthFile /home/alpha/.tor/control_auth_cookie

Then I switched over to the regular Tor service with the settings from the docs and your additional steps but would still get a Permission Denied related to the cookie file.
I found out that the chmod g+x /var/lib/tor/ gets automatically reverted by Tor upon start (Fixing permission step).

The only way so far to get it working is to start Tor via systemctl then manually change the permission of /var/lib/tor before starting Zeronet. This still doesn't work with the Vidalia front-end.

This page is a snapshot of ZeroNet. Start your own ZeroNet for complete experience. Learn More