? Editing: Post:21.body Save Delete Cancel

ArchLinux.net

Welcome to the ArchLinux forum!

+ Create new topic
Please wait...

Title

Body
^1 ^2 added ━ submitted by user_name

Main ZeroNet news How did you find ZeroNet?

Legacy namecoin-core, why?

How come namecoin-core from AUR gives you legacy namecoin v0.3.80 instead of the revamped namecoin-core (currently v0.12.0)? The old namecoin doesn't even support IPv6, and the “new” namecoin-core has a lot of added functionality.

^1 ^2 ks posted on Mar 06, 2016
Please sign innew comment
user_nameadded ^1 ^2
Reply
Body
jzaon Jul 21, 2016 ^1 ^2
Reply

I finally gave up and just got the git repo, and was able to compile from source. I am still using namecoin-cli instead of qt. Anyone have given a try to the current master?

kson Mar 15, 2016 ^1 ^2
Reply

I don't get why people say there is no wallet features in namecoin-core. I have the latest namecoin-core installed, and namecoin-cli says “Namecoin Core RPC client version v0.12.99.0-20c2dac”. That's the one I use to send wallet commands to namecoind.

jzaon Mar 14, 2016 ^1 ^2
Reply

I was fainally able to get namecoin-core running but it didnt had any wallet features so I couldnt register the domains, I had to go to this tutorial and had to download their namecoind version 3.5 unfortunately it made me download a huge blockchain (40GB+) but gave me some wallet functionality. I cant see any key management., like dumpprivkey or importkey.
http://www.christopherpoole.net/registering-a-bit-domain-with-namecoin.html

basxtoon Mar 12, 2016 ^1 ^2
Reply

oops sorry … -.-

line 100 shouldn't be there, accidentially pasted that in there

jzaon Mar 12, 2016 ^1 ^2
Reply

@basxto tried your patched PKGBUILD but got another error on the .conf
PKGBUILD: line 100: -conf=../.namecoin/namecoin.conf: No such file or directory
I assume this is related to the overal path of the build instead of being a $HOME/.namecoin/namecoin.conf

jzaon Mar 12, 2016 ^1 ^2
Reply

I got the same error to bitcoin, seems that all the binaries are on the original bitcoin names, including the /usr/bin/bitcoind binary, this makes it collide with other bitcoin wallets.
There needs to be some re-engineering of the make code.
BTW I couldnt find the paste you did, it said the paste is no longer available.

basxtoon Mar 10, 2016 ^1 ^2
Reply

this is the ‘fixed’ PKGBUILD: http://127.0.0.1:43110/1MgHVPCE1ve6QfKrgsqCURzRj72HrRWioz/?1PVcdu7USZH2kHMETbqDYLPjJZKCDWM52k_7

systemctl start namecoin
namecoin-cli -conf=../.namecoin/namecoin.conf help
basxtoon Mar 10, 2016 ^1 ^2
Reply

can't build that one, get

install: cannot stat 'contrib/debian/manpages/namecoind.1': No such file or directory

like the other guy in the comments

kson Mar 10, 2016 ^1 ^2
Reply

The package is now offering the latest namecoin-core. Nice!

This page is a snapshot of ZeroNet. Start your own ZeroNet for complete experience. Learn More